Uploaded image for project: 'Helm'
  1. Helm
  2. HELM-211

Grafana dependency should be updated and should be more specific

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.0.2
    • Fix Version/s: None
    • Component/s: Docs
    • Labels:
      None

      Description

      When installing OpenNMS Helm we rely on Grafana. In the documentation we tell vary vague a Grafana between 4.4.1 < 6 is required. The latest version of Grafana today is 6.5.3 and it seems like our plugin can only be used up to the latest 6.4.5 version and is not compatible with the latest stable 6.5.3 version. We should be more specific with the compatible version number. The latest dependency in Helm itself is set to "@grafana/data": "^6.4.3",.

      https://docs.opennms.org/helm/releases/4.0.0/helm/latest/installation/requirements.html

        Attachments

          Activity

            People

            Assignee:
            Bonnie Bonnie Robinson
            Reporter:
            indigo Ronny Trommer
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 30 minutes
                30m