Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-11423

Create RPM packages for the elasticsearch-drift-plugin

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Security Level: Default (Default Security Scheme)
    • Labels:
    • Epic Link:
    • Sprint:
      Horizon - Feb 21st 2018, Horizon - March 14th 2018, Horizon - March 21st 2018, Horizon - April 4th 2018

      Description

      We should provide RPM packages for our elasticsearch-drift-plugin that depend on the specific Elasticsearch version for which they are built.

      When compiling the project, an assembly is created in target/releases.

      Installing the plugin involves overlaying the assembly as follows:

      $ pwd
      /usr/share/elasticsearch/plugins
      $ tree .
      .
      └── drift
          ├── aggs-matrix-stats-client-6.1.1.jar
          ├── elasticsearch-drift-plugin-1.0.0.jar
          ├── LICENSE.txt
          └── plugin-descriptor.properties
      
      1 directory, 4 files
      

        Attachments

          Activity

            People

            Assignee:
            ranger Benjamin Reed
            Reporter:
            j-white Jesse White
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: