Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-11533

Create upgrade script for service-configuration.xml

    XMLWordPrintable

Details

    • Story
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Fixed
    • 17.0.0
    • 17.1.0
    • Installation
    • Security Level: Default (Default Security Scheme)
    • None
    • 1
    • November Releases Sprint

    Description

      To avoid startup issues for people with old configs, we need to provide an upgrade script for service-configuration.xml to remove MX4J, Linkd, Xmlrpcd, and AccessPointMonitor beans which were removed in 17.0.0.

      git diff origin/release-16.0.4..origin/release-17.0.0 opennms-base-assembly/src/main/filtered/etc/service-configuration.xml

      Attachments

        Activity

          People

            ranger Benjamin Reed
            seth Seth Leger
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: