Uploaded image for project: 'OpenNMS Horizon'
  1. OpenNMS Horizon
  2. HZN-620

Minion should depend on a JRE instead of a JDK

    Details

      Description

      We currently require a JDK for access to the 'com.sun.tools.attach' package which is required by org.opennms.core/org.opennms.core.daemon on which the "discoverer" feature depends.

      We don't actually need this class, so we should break up the dependencies accordingly.

      Once we no longer need the JDK to run, we need to:
      1) Modify the package spec to depend on a JRE instead of a JDK
      2) Remove the custom jre.properties we bundle with the container

        Attachments

          Activity

            People

            • Assignee:
              ranger Benjamin Reed
              Reporter:
              j-white Jesse White
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: