Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-11501

Upgrade Camel to version 2.16

    XMLWordPrintable

    Details

    • Type: Story
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 18.0.0
    • Fix Version/s: 20.0.0
    • Component/s: Build / Packaging
    • Security Level: Default (Default Security Scheme)
    • Labels:
      None

      Description

      The Camel release notes indicate that version 2.17 will be the last version that officially supports our old version of Karaf. We should upgrade to it during the OpenNMS 19 release cycle to get the latest bugfixes. According to their release notes there are more fixes for Karaf integration tests which is something that we see crop up in our builds occasionally.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              seth Seth Leger (Inactive)
              Reporter:
              seth Seth Leger (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Git Integration