Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-12119

Installing Minion on Debian with OpenJDK 11 installed tries to install Oracle JDK 8

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 24.1.0
    • Fix Version/s: 24.1.1
    • Component/s: Installation
    • Security Level: Default (Default Security Scheme)
    • Labels:
      None
    • Sprint:
      Horizon 2019 - June 12th 2020, Horizon 2019 - June 19th 2019

      Description

      I'm trying to build a Docker image based on openjdk:11-jdk, because in order to use Docker images with GNS3, the images must be based on Debian. The official OpenJDK image is based on Debian, so I though that can be a good start.

      First, I've tried to do it manually, and I found the problem.

      Here is the whole procedure:

      $ docker run -it --rm openjdk:11-jdk bash
      Unable to find image 'openjdk:11-jdk' locally
      11-jdk: Pulling from library/openjdk
      6f2f362378c5: Pull complete
      494c27a8a6b8: Pull complete
      7596bb83081b: Pull complete
      372744b62d49: Pull complete
      fb72767f9beb: Pull complete
      c34cefad6b24: Pull complete
      e2b76c865b34: Pull complete
      Digest: sha256:b510eef40fcde8f60f65a2ed382f2a7e31a95ea1c78bc5abea44cf637e37a188
      Status: Downloaded newer image for openjdk:11-jdk
      
      root@a22e54383965:/# cat /etc/os-release
      PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
      NAME="Debian GNU/Linux"
      VERSION_ID="9"
      VERSION="9 (stretch)"
      ID=debian
      HOME_URL="https://www.debian.org/"
      SUPPORT_URL="https://www.debian.org/support"
      BUG_REPORT_URL="https://bugs.debian.org/"
      
      root@a22e54383965:/# apt-get update
      Ign:1 http://deb.debian.org/debian stretch InRelease
      Get:2 http://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]
      Get:3 http://deb.debian.org/debian stretch-updates InRelease [91.0 kB]
      Get:4 http://deb.debian.org/debian stretch Release [118 kB]
      Get:5 http://deb.debian.org/debian stretch Release.gpg [2434 B]
      Get:6 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [497 kB]
      Get:7 http://deb.debian.org/debian stretch-updates/main amd64 Packages [27.2 kB]
      Get:8 http://deb.debian.org/debian stretch/main amd64 Packages [7082 kB]
      Fetched 7912 kB in 2s (3931 kB/s)
      Reading package lists... Done
      
      root@a22e54383965:/# apt-get upgrade
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Calculating upgrade... Done
      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      
      root@a22e54383965:/# apt-get install apt-transport-https
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      The following NEW packages will be installed:
        apt-transport-https
      0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      Need to get 171 kB of archives.
      After this operation, 243 kB of additional disk space will be used.
      Get:1 http://deb.debian.org/debian stretch/main amd64 apt-transport-https amd64 1.4.9 [171 kB]
      Fetched 171 kB in 0s (1743 kB/s)
      debconf: delaying package configuration, since apt-utils is not installed
      Selecting previously unselected package apt-transport-https.
      (Reading database ... 12446 files and directories currently installed.)
      Preparing to unpack .../apt-transport-https_1.4.9_amd64.deb ...
      Unpacking apt-transport-https (1.4.9) ...
      Setting up apt-transport-https (1.4.9) ...
      
      root@a22e54383965:/# echo "deb https://debian.opennms.org stable main" | tee /etc/apt/sources.list.d/opennms.list 
      
      root@a22e54383965:/# wget -O - https://debian.opennms.org/OPENNMS-GPG-KEY | apt-key add - --2019-06-17 16:37:45-- https://debian.opennms.org/OPENNMS-GPG-KEY Resolving debian.opennms.org (debian.opennms.org)... 172.20.1.28, 2600:5800:fc29:3::1c Connecting to debian.opennms.org (debian.opennms.org)|172.20.1.28|:443... connected. HTTP request sent, awaiting response... 200 OK Length: 1725 (1.7K) Saving to: ‘STDOUT’- 100%[================================================================>] 1.68K --.-KB/s in 0s2019-06-17 16:37:46 (37.5 MB/s) - written to stdout [1725/1725]OK 
      
      root@a22e54383965:/# apt-get update
      Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
      Ign:2 http://deb.debian.org/debian stretch InRelease
      Hit:3 http://deb.debian.org/debian stretch-updates InRelease
      Hit:4 http://deb.debian.org/debian stretch Release
      Ign:5 https://debian.opennms.org stable InRelease
      Hit:6 https://debian.opennms.org stable Release
      Get:7 https://debian.opennms.org stable Release.gpg [224 B]
      Fetched 224 B in 0s (539 B/s)
      Reading package lists... Done
      W: Conflicting distribution: https://debian.opennms.org stable Release (expected stable but got opennms-24)
      
      root@a22e54383965:/# apt-get install opennms-minion
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      The following additional packages will be installed:
        binutils gsfonts gsfonts-x11 java-common jicmp jicmp6 libc-l10n libfontenc1 libxfont1 locales opennms-minion-container
        opennms-minion-features-core opennms-minion-features-default oracle-java8-installer oracle-java8-set-default sudo uuid-runtime
        x11-common xfonts-encodings xfonts-utils
      Suggested packages:
        binutils-doc binfmt-support visualvm ttf-baekmuk | ttf-unfonts | ttf-unfonts-core ttf-kochi-gothic | ttf-sazanami-gothic
        ttf-kochi-mincho | ttf-sazanami-mincho ttf-arphic-uming firefox | firefox-2 | iceweasel | mozilla-firefox | iceape-browser
        | mozilla-browser | epiphany-gecko | epiphany-webkit | epiphany-browser | galeon | midbrowser | moblin-web-browser | xulrunner
        | xulrunner-1.9 | konqueror | chromium-browser | midori | google-chrome
      The following NEW packages will be installed:
        binutils gsfonts gsfonts-x11 java-common jicmp jicmp6 libc-l10n libfontenc1 libxfont1 locales opennms-minion opennms-minion-container
        opennms-minion-features-core opennms-minion-features-default oracle-java8-installer oracle-java8-set-default sudo uuid-runtime
        x11-common xfonts-encodings xfonts-utils
      0 upgraded, 21 newly installed, 0 to remove and 0 not upgraded.
      Need to get 249 MB of archives.
      After this operation, 341 MB of additional disk space will be used.
      Do you want to continue? [Y/n] Y
      Get:1 http://deb.debian.org/debian stretch/main amd64 binutils amd64 2.28-5 [3770 kB]
      Get:2 https://debian.opennms.org stable/main amd64 oracle-java8-installer all 8u131-1~webupd8~2 [34.3 kB]
      Get:3 https://debian.opennms.org stable/main amd64 oracle-java8-set-default all 8u131-1~webupd8~2 [7352 B]
      Get:4 https://debian.opennms.org stable/main amd64 jicmp amd64 2.0.2-1 [35.6 kB]
      Get:5 https://debian.opennms.org stable/main amd64 jicmp6 amd64 2.0.2-1 [17.7 kB]
      Get:6 https://debian.opennms.org stable/main amd64 opennms-minion-container all 24.1.0-1 [68.6 MB]
      Get:7 http://deb.debian.org/debian stretch/main amd64 java-common all 0.58+deb9u1 [13.6 kB]
      Get:8 http://deb.debian.org/debian stretch/main amd64 libc-l10n all 2.24-11+deb9u4 [820 kB]
      Get:9 http://deb.debian.org/debian stretch/main amd64 locales all 2.24-11+deb9u4 [3289 kB]
      Get:10 http://deb.debian.org/debian stretch/main amd64 uuid-runtime amd64 2.29.2-1+deb9u1 [82.6 kB]
      Get:11 http://deb.debian.org/debian stretch/main amd64 gsfonts all 1:8.11+urwcyr1.0.7~pre44-4.3 [3126 kB]
      Get:12 http://deb.debian.org/debian stretch/main amd64 libfontenc1 amd64 1:1.1.3-1+b2 [24.4 kB]
      Get:13 http://deb.debian.org/debian stretch/main amd64 libxfont1 amd64 1:1.5.2-4 [136 kB]
      Get:14 http://deb.debian.org/debian stretch/main amd64 x11-common all 1:7.7+19 [251 kB]
      Get:15 http://deb.debian.org/debian stretch/main amd64 xfonts-encodings all 1:1.0.4-2 [574 kB]
      Get:16 http://deb.debian.org/debian stretch/main amd64 xfonts-utils amd64 1:7.7+4 [77.2 kB]
      Get:17 http://deb.debian.org/debian stretch/main amd64 gsfonts-x11 all 0.24 [8922 B]
      Get:18 http://deb.debian.org/debian stretch/main amd64 sudo amd64 1.8.19p1-2.1 [1055 kB]
      Get:19 https://debian.opennms.org stable/main amd64 opennms-minion-features-core all 24.1.0-1 [28.1 MB]
      Get:20 https://debian.opennms.org stable/main amd64 opennms-minion-features-default all 24.1.0-1 [139 MB]
      Get:21 https://debian.opennms.org stable/main amd64 opennms-minion all 24.1.0-1 [13.3 kB]
      Fetched 249 MB in 9s (25.8 MB/s)
      debconf: delaying package configuration, since apt-utils is not installed
      Selecting previously unselected package binutils.
      (Reading database ... 12452 files and directories currently installed.)
      Preparing to unpack .../binutils_2.28-5_amd64.deb ...
      Unpacking binutils (2.28-5) ...
      Selecting previously unselected package java-common.
      Preparing to unpack .../java-common_0.58+deb9u1_all.deb ...
      Unpacking java-common (0.58+deb9u1) ...
      Selecting previously unselected package libc-l10n.
      Preparing to unpack .../libc-l10n_2.24-11+deb9u4_all.deb ...
      Unpacking libc-l10n (2.24-11+deb9u4) ...
      Selecting previously unselected package locales.
      Preparing to unpack .../locales_2.24-11+deb9u4_all.deb ...
      Unpacking locales (2.24-11+deb9u4) ...
      Setting up binutils (2.28-5) ...
      Selecting previously unselected package oracle-java8-installer.
      (Reading database ... 13413 files and directories currently installed.)
      Preparing to unpack .../oracle-java8-installer_8u131-1~webupd8~2_all.deb ...
      debconf: unable to initialize frontend: Dialog
      debconf: (No usable dialog-like program is installed, so the dialog based frontend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 76.)
      debconf: falling back to frontend: Readline
      Configuring oracle-java8-installer
      ----------------------------------Oracle Binary Code License Agreement for the Java SE Platform Products and JavaFXYou MUST agree to the license available in http://java.com/license if you want to use Oracle JDK.In order to install this package, you must accept the license terms, the "Oracle Binary Code License Agreement for the Java SE Platform
      Products and JavaFX ". Not accepting will cancel the installation.Do you accept the Oracle Binary Code license terms? [yes/no] noDeclined "Oracle Binary Code License for Java"If you do not agree to the license terms you cannot install this software.The installation of this package will be canceled.user did not accept the oracle-license-v1-1 license
      dpkg: error processing archive /var/cache/apt/archives/oracle-java8-installer_8u131-1~webupd8~2_all.deb (--unpack):
       subprocess new pre-installation script returned error exit status 1
      Errors were encountered while processing:
       /var/cache/apt/archives/oracle-java8-installer_8u131-1~webupd8~2_all.deb
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      root@a22e54383965:/# 

        Attachments

          Activity

            People

            • Assignee:
              ranger Benjamin Reed
              Reporter:
              agalue Alejandro Galue
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: