Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-12121

Opennms 24.1.0 on Ubuntu 19.04 won’t install because of PostgreSQL 11

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 24.1.0
    • Fix Version/s: 24.1.1
    • Component/s: Build / Packaging
    • Security Level: Default (Default Security Scheme)
    • Labels:
      None
    • Environment:
      Ubuntu Server 19.04

      Description

      opennms 24.1.0-1 depends from opennms-db (=24.1.0-1)
      which depends from Postgresql (from 9.1 to 10)
      but Ubuntu server 19.04 provides Postgresql 11 and opennms installation is blocked because it can't install opennms-db.

      in attachment I've got only screenshots, the first shows that opennms won't install by opennms-db unsatisfied dependency, the second shows dependencies of opennms-db

      related Pull Request

        Attachments

          Activity

            People

            Assignee:
            ranger Benjamin Reed
            Reporter:
            caminac Carlo Caminati
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: