Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-12688

Streaming Telemetry is broken when using OpenJDK 11 and minion

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Fixed
    • 26.0.0, Meridian-2019.1.6
    • Meridian-2019.1.7, 26.1.0
    • Telemetry
    • Security Level: Default (Default Security Scheme)
    • None

    Description

      I was performing some tests with NX-OS Telemetry in Docker and found the solution was not working because of the following error on telemetryd.log

      https://paste.opennms.eu/uviyoqejur.pl

      It turns out that the smoke-tests for Telemetry are running with JDK 8, so I decided to rebuild the Docker Image to use OpenJDK 8 instead of OpenJDK 11.

      After restarting the environment, everything started to work as expected, the error is gone, the adapter executes the Groovy, and I can see the RRD files updated without issues.

      Something seems missing when using OpenJDK 11 leading to the AOP/Spring errors mentioned on the above link that the smoke tests never caught because they use JDK 8 to run.

      Attachments

        Activity

          People

            cgorantla Chandra Gorantla
            agalue Alejandro Galue
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.