Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-4396

yum update from 1.8.7 to 1.8.8 is breaking opennms

    Details

      Description

      I have 1.8.7 installed.
      I run a "yum update" to install the 1.8.8-1 new available stable release.
      After I run the install program to configure database : /opt/opennms/bin/install -dis

      I got some error while executing even if it displayed a "Installer completed successfully!" at the end.
      You can see the log in the attached file "opennms_install_dis.log"

      The first error was about a database constraint :
      liquibase.exception.JDBCException: Error executing SQL ALTER TABLE datalinkinterface DROP CONSTRAINT pk_datalinkinterface

      And after that I was unable to start again OpenNMS :

      [root@dtc-srvtest1][1207][/opt/opennms/etc] #service opennms start
      Starting OpenNMS: OpenNMS was unable to connect to the 'opennms' database configured in opennms-datasources.xml.
      [FAILED]
      [root@dtc-srvtest1][1208][/opt/opennms/etc] #

        Attachments

          Activity

            People

            • Assignee:
              ranger Benjamin Reed
              Reporter:
              mannu mannu
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: