Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-4412

When an IP is configured on an interface, the interface name is no longer visible in Node Link Detailed Info

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.7, 1.8.9
    • Fix Version/s: 1.9.92
    • Component/s: Enhanced Linkd / Linkd
    • Security Level: Default (Default Security Scheme)
    • Labels:
      None
    • Environment:

      Description

      I have a couple of different Cisco devices that have been discovered (ME3400 IOS 12.2(54)SE, ME3600 IOS 12.2(52)EY, ASR9000 IOS-XR 4.0.1) When I go to view that node's Link Detailed Info, I notice that for interfaces on the node that do not have IP addresses configured on them, the Info screen shows the Interface field labeled as the interface name, ie GigabitEthernet0/1/0/0, the Description field is populated with the same interface name and the ifAlias field is populated with whatever interface description has been applied to the interface configuration on the node.

      Conversely, for interfaces on the node that have IP addresses configured on them, the Info screen shows the Interface field labeled as the IP address of the interface with the Description and ifAlias fields both being blank (even though there is a description configured on the interface).

      Example 1:
      !
      interface GigabitEthernet0/1
      description Facing 49Spadina-1 Gi0/2, FPP1 #2, BBF #5 BX-D(purple)
      port-type nni
      switchport trunk allowed vlan 456,468,920,921
      switchport mode trunk
      !

      Example 2:
      !
      interface FastEthernet0/1
      description 010025870004 En Vogue Computers/703-100 Adelaide St W
      no switchport
      ip address 96.45.199.241 255.255.255.252
      ip access-group 102 in
      no ip unreachables
      speed 10
      !

      In the case of example 1, Node Link Detailed Info shows the "Interface" column as "Gi0/1", "Description" column as "GigabitEthernet0/1" and "ifAlias" column as "Facing 49Spadina-1 Gi0/2, FPP1 #2, BBF #5 BX-D(purple)".

      In the case of example 2, Node Link Detailed info shows the "Interface" column as "96.45.199.241", Description" column as blank and "ifAlias" column as blank.

      Even though there is an IP address the interface, I would still expect to see the actual interface and/or description and ifAlias in there somewhere.

      On 1.8.4 polling a Cisco 6509 12.2(33)SXH box, I see the expected behaviour using a configuration similar to example 2. In see the "Interface" column as "76.75.100.250", "Description" column as "GabitEthernet9/47" and "ifAlias" column as "** NEXICOM - TRANSIT".

        Attachments

          Activity

            People

            • Assignee:
              desloge Donald Desloge
              Reporter:
              jlixfeld Jason Lixfeld
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: