Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-6623

Update JNA.jar library to support ARM based systems

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • 1.12.8
    • 18.0.0
    • Architecture
    • Security Level: Default (Default Security Scheme)
    • Hardkernel Odroid U3, Exynos4412 Prime ARM A9 Quad Core @ 1,7 GHz, 2 GB RAM, 16 GB eMMC, Ubuntu 14.04 LTS

    Description

      The current JNA.jar (Version 3.2.7) is missing jnidispatch for ARM system platforms (/com/sun/jna/linux-arm/libjnidispatch.so).
      This was introduced in Version 3.4.1 (latest JNA Version is 4.0.0).

      Until JNA is migrated to 3.4.1 or higher OpenNMS can not be started on any ARM based systems.

      Attachments

        Issue Links

          Activity

            People

              ranger Benjamin Reed
              philipsannwald Philip Sannwald (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: