Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-7023

Installation on Ubuntu 14.04 failes for unmet dependencies

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.13.4
    • Fix Version/s: 14.0.0
    • Component/s: Installation
    • Security Level: Default (Default Security Scheme)
    • Labels:
      None

      Description

      If you try to install OpenNMS snapshot on Ubuntu 14.04 you run in the following error message:

      root@vagrant:~# aptitude install opennms
      The following NEW packages will be installed:
       heirloom-mailx{a} libauthen-sasl-perl{a} libdbd-pg-perl{a} libdbi-perl{a} libencode-locale-perl{a}
       libfile-listing-perl{a} libfont-afm-perl{a} libgetopt-mixed-perl{a} libhtml-form-perl{a}
       libhtml-format-perl{a} libhtml-parser-perl{a} libhtml-tagset-perl{a} libhtml-tree-perl{a}
       libhttp-cookies-perl{a} libhttp-daemon-perl{a} libhttp-date-perl{a} libhttp-message-perl{a}
       libhttp-negotiate-perl{a} libio-html-perl{a} libio-socket-inet6-perl{a} libio-socket-ssl-perl{a}
       liblwp-mediatypes-perl{a} liblwp-protocol-https-perl{a} libmailtools-perl{a} libnet-http-perl{a}
       libnet-smtp-ssl-perl{a} libnet-snmp-perl{a} libnet-ssleay-perl{a} libopennms-java{ab} libopennmsdeps-java{a}
       libsocket6-perl{a} libtie-ixhash-perl{a} liburi-perl{a} libwww-perl{a} libwww-robotrules-perl{a}
       libxml-parser-perl{a} libxml-twig-perl{a} libxml-xpathengine-perl{a} libxml2-utils{a} opennms
       opennms-common{a} opennms-db{ab} opennms-server{a} opennms-webapp-jetty{a}
      0 packages upgraded, 44 newly installed, 0 to remove and 0 not upgraded.
      Need to get 352 MB of archives. After unpacking 482 MB will be used.
      The following packages have unmet dependencies:
      opennms-db : Depends: iplike-pgsql93 which is a virtual package. or
                            iplike-pgsql92 which is a virtual package. or
                            iplike-pgsql91 which is a virtual package. or
                            iplike-pgsql90 (>= 1.0.8) which is a virtual package. or
                            iplike-pgsql84 (>= 1.0.8) which is a virtual package.
      libopennms-java : Depends: jicmp which is a virtual package.
                        Depends: jicmp6 which is a virtual package.
      The following actions will resolve these dependencies:
      
          Keep the following packages at their current version:
      1)     libopennms-java [Not Installed]
      2)     opennms [Not Installed]
      3)     opennms-db [Not Installed]
      4)     opennms-server [Not Installed]
      5)     opennms-webapp-jetty [Not Installed]
      
      Accept this solution? [Y/n/q/?]
      

      The information for the Debian packages are:

      Abort.
      root@vagrant:~# aptitude show opennms
      Package: opennms
      State: not installed
      Version: 14.0.0-0.20141015.rc.stable.1.14.0.70
      Priority: optional
      Section: contrib/net
      Maintainer: Jeff Gehlbach <jeffg@opennms.org>
      Architecture: all
      Uncompressed Size: 2,048
      Depends: opennms-db (= 14.0.0-0.20141015.rc.stable.1.14.0.70), opennms-server (=
               14.0.0-0.20141015.rc.stable.1.14.0.70), opennms-webapp-jetty (= 14.0.0-0.20141015.rc.stable.1.14.0.70)
      Suggests: opennms-doc
      Description: Enterprise-grade Open-source Network Management Platform (Full Install)
       OpenNMS is an enterprise-grade network management system written in Java.
      
       OpenNMS can monitor various network services to determine status and service level availability.  Data collection
       is performed using protocols such as SNMP to generate reports and alert on thresholds.  An extensible event
       management and notification system handles both internally and externally generated events (such as SNMP traps),
       and generates notices via email, pager, SMS, etc.
      
       This package provides the components needed for a reasonable default installation of OpenNMS.
      

        Attachments

          Activity

            People

            • Assignee:
              ranger Benjamin Reed
              Reporter:
              indigo Ronny Trommer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: