Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-7080

Unable to resolve missing requirement while navigating to the web frontend

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Fixed
    • 14.0.0
    • 14.0.0
    • Security Level: Default (Default Security Scheme)
    • None
    • Windows 8.1 (VM)

    Description

      When OpenNMS is running on a windows machine and I navigate to the web frontend (http://localhost:8980/opennms) an "Unresolved constraint in bundle org.ops4j.pax.web.pax-web-jsp" Exception is thrown.

      ERROR: Bundle org.ops4j.pax.web.pax-web-jsp [30] Error starting mvn:org.ops4j.pax.web/pax-web-jsp/3.1.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.web.pax-web-jsp [30]: Unable to resolve 30.0: missing requirement [30.0] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.web.utils)(version>=3.1.0)(!(version>=4.0.0))))
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.web.pax-web-jsp [30]: Unable to resolve 30.0: missing requirement [30.0] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.web.utils)(version>=3.1.0)(!(version>=4.0.0)))
      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
      at java.lang.Thread.run(Thread.java:745)
      Creating topology provider

      Attachments

        Issue Links

          Activity

            People

              seth Seth Leger
              mvr Markus von RĂ¼den
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: