Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-8049

Documentation for Cassandra/Newts doesn't mention that a JDK is required

    XMLWordPrintable

    Details

      Description

      I was following the procedure to install a Cassandra node from scratch from:

      http://docs.opennms.org/opennms/releases/17.0.0/guide-install/guide-install.html#gi-setup-cassandra

      That procedure doesn't mention the fact that Cassandra requires Java, and the RPM of Cassandra doesn't install Java. I think that the documentation has to be updated to let the users know that they have to install Java prior start using Cassandra.

      What version of Java ? Whatever Apache recommends for Cassandra.

      I used:

      yum install http://yum.opennms.org/stable/common/jdk/x64/jdk-8u60-linux-x64.rpm

        Attachments

          Activity

            People

            • Assignee:
              indigo Ronny Trommer
              Reporter:
              agalue Alejandro Galue
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: