Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-8156

Upgrade Angular Backend for the Requisitions UI

    XMLWordPrintable

    Details

      Description

      The original implementation of the requisitions UI was based on AngularJS 1.2.28. Besides that, it uses Angular-UI Bootstrap and other dependencies.

      Because of some limitations of the Angular-UI Bootstrap, some hacks have been added to make the typeahead functionality to work properly.

      With AngularJS 1.4.9 and Angular-UI Bootstrap 1.1.2, the hack is not required anymore, as the typeahead component now works as expected. This simplifies the current code and make available to all users, all the improvements and bug fixes on these 2 libraries.

        Attachments

          Activity

            People

            • Assignee:
              agalue Alejandro Galue
              Reporter:
              agalue Alejandro Galue
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: