Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-8900

Spurious Trapd error logs: unknown SNMP protocol version 'v2'

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 18.0.2, Meridian-2016.1.3
    • Fix Version/s: 18.0.3, Meridian-2016.1.4
    • Security Level: Default (Default Security Scheme)
    • Labels:
    • Environment:
      Unsure about exactly what triggers this, but it's been seen in the wild in a couple of different environments.

      Description

      Trapd sometimes logs the following scary-looking message at ERROR severity:

      Received a trap with an unknown SNMP protocol version 'v2'

      The message is produced by accounting code in the TrapQueueProcessor class, which recognizes only v2c and not v2 when counting traps received using protocol version 2; it should treat the two values as equivalent. This message happens because some events derived from SNMPv2c traps end up having v2 rather than v2c recorded as their protocol version.

      The impact should be limited to log noise (which could be quite significant in busy installs) and miscounted traps in the Trapd JMX statistics.

        Attachments

          Activity

            People

            • Assignee:
              jeffg Jeff Gehlbach
              Reporter:
              jeffg Jeff Gehlbach
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: