Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-9086

osgi-pluginmanager: Include support for Karaf 4

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Fixed
    • 19.0.0
    • 20.0.0
    • OSGi
    • Security Level: Default (Default Security Scheme)
    • None

    Description

      The OSGi metadata for the org.opennms.plugin.featuremanager bundle excludes support for Apache Karaf versions higher than 2.X. We need to change the metadata to allow compatibility all the way up to Karaf 4.X.

      Attachments

        Issue Links

          Activity

            People

              seth Seth Leger
              seth Seth Leger
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: