Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-9123

Bundle error in output.log on startup

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Fixed
    • 19.0.0
    • 19.0.1
    • OSGi
    • Security Level: Default (Default Security Scheme)
    • None
    • Horizon - Feb 1st, Horizon - Feb 8th, Horizon - Feb 15th

    Description

      When starting up the latest snapshots of 19.0.0, the following error shows up in output.log:

      ERROR: Bundle org.opennms.core.ipc.sink.xml [196] Error starting mvn:org.opennms.core.ipc.sink/org.opennms.core.ipc.sink.xml/19.0.0-SNAPSHOT (org.osgi.framework.BundleException: Unresolved constraint in bundle org.opennms.core.ipc.sink.xml [196]: Unable to resolve 196.0: missing requirement [196.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.core.ipc.sink.api)(version>=19.0.0)(!(version>=20.0.0))))
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.opennms.core.ipc.sink.xml [196]: Unable to resolve 196.0: missing requirement [196.0] osgi.wiring.package; (&(osgi.wiring.package=org.opennms.core.ipc.sink.api)(version>=19.0.0)(!(version>=20.0.0)))
              at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
              at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
              at java.lang.Thread.run(Thread.java:745)
      

      Attachments

        Activity

          People

            seth Seth Leger
            j-white Jesse White
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: