Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-9410

Can't install OpenNMS caused by libopennms-java dependency problems

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 19.1.0, 20.0.0
    • Fix Version/s: 20.0.0
    • Component/s: Build / Packaging
    • Security Level: Default (Default Security Scheme)
    • Labels:
      None

      Description

      When I try to install OpenNMS on Ubuntu 16.04 LTS minimal server from official OpenNMS repository gives the following error message:

      Reading state information... Done
      The following additional packages will be installed:
        binutils gsfonts gsfonts-x11 iplike-pgsql95 java-common jicmp jicmp6 libauthen-sasl-perl libdbd-pg-perl libdbi-perl
        libencode-locale-perl libfile-listing-perl libfont-afm-perl libfontenc1 libgetopt-mixed-perl libhtml-form-perl libhtml-format-perl
        libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl
        libhttp-message-perl libhttp-negotiate-perl libio-html-perl libio-socket-ssl-perl liblwp-mediatypes-perl liblwp-protocol-https-perl
        libmailtools-perl libnet-http-perl libnet-smtp-ssl-perl libnet-snmp-perl libnet-ssleay-perl libopennms-java libopennmsdeps-java
        libtie-ixhash-perl libtimedate-perl liburi-perl libwww-perl libwww-robotrules-perl libxfont1 libxml-parser-perl libxml-twig-perl
        libxml-xpathengine-perl libxml2-utils opennms-common opennms-db opennms-server opennms-source opennms-webapp-jetty
        oracle-java8-installer oracle-java8-set-default s-nail x11-common xfonts-encodings xfonts-utils
      Suggested packages:
        binutils-doc libdigest-hmac-perl libgssapi-perl libclone-perl libmldbm-perl libnet-daemon-perl libsql-statement-perl
        libdata-dump-perl libcrypt-ssleay-perl libcrypt-des-perl libio-socket-inet6-perl libauthen-ntlm-perl libunicode-map8-perl
        libunicode-string-perl xml-twig-tools opennms-doc jrrd2 rrdtool binfmt-support visualvm ttf-baekmuk | ttf-unfonts
        | ttf-unfonts-core ttf-kochi-gothic | ttf-sazanami-gothic ttf-kochi-mincho | ttf-sazanami-mincho ttf-arphic-uming firefox
        | firefox-2 | iceweasel | mozilla-firefox | iceape-browser | mozilla-browser | epiphany-gecko | epiphany-webkit | epiphany-browser
        | galeon | midbrowser | moblin-web-browser | xulrunner | xulrunner-1.9 | konqueror | chromium-browser | midori | google-chrome
        exim4 | mail-transport-agent
      The following NEW packages will be installed:
        binutils gsfonts gsfonts-x11 iplike-pgsql95 java-common jicmp jicmp6 libauthen-sasl-perl libdbd-pg-perl libdbi-perl
        libencode-locale-perl libfile-listing-perl libfont-afm-perl libfontenc1 libgetopt-mixed-perl libhtml-form-perl libhtml-format-perl
        libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl
        libhttp-message-perl libhttp-negotiate-perl libio-html-perl libio-socket-ssl-perl liblwp-mediatypes-perl liblwp-protocol-https-perl
        libmailtools-perl libnet-http-perl libnet-smtp-ssl-perl libnet-snmp-perl libnet-ssleay-perl libopennms-java libopennmsdeps-java
        libtie-ixhash-perl libtimedate-perl liburi-perl libwww-perl libwww-robotrules-perl libxfont1 libxml-parser-perl libxml-twig-perl
        libxml-xpathengine-perl libxml2-utils opennms opennms-common opennms-db opennms-server opennms-source opennms-webapp-jetty
        oracle-java8-installer oracle-java8-set-default s-nail x11-common xfonts-encodings xfonts-utils
      0 upgraded, 58 newly installed, 0 to remove and 0 not upgraded.
      Need to get 598 MB of archives.
      After this operation, 784 MB of additional disk space will be used.
      Get:1 http://debian.opennms.org stable/main amd64 oracle-java8-installer all 8u111+8u111arm-1~webupd8~0 [24.2 kB]
      Get:2 http://archive.ubuntu.com/ubuntu xenial/main amd64 libfontenc1 amd64 1:1.1.3-1 [13.9 kB]
      Get:3 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxfont1 amd64 1:1.5.1-1 [94.7 kB]
      Get:4 http://debian.opennms.org stable/main amd64 jicmp amd64 2.0.2-1 [35.6 kB]
      Get:5 http://debian.opennms.org stable/main amd64 jicmp6 amd64 2.0.2-1 [17.7 kB]
      Get:6 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 binutils amd64 2.26.1-1ubuntu1~16.04.3 [2,310 kB]
      Get:7 http://debian.opennms.org stable/main amd64 libopennms-java all 19.1.0-1 [7,607 kB]
      Get:8 http://archive.ubuntu.com/ubuntu xenial/main amd64 java-common all 0.56ubuntu2 [7,742 B]
      Get:9 http://archive.ubuntu.com/ubuntu xenial/main amd64 gsfonts all 1:8.11+urwcyr1.0.7~pre44-4.2ubuntu1 [3,374 kB]
      Get:10 http://archive.ubuntu.com/ubuntu xenial/main amd64 x11-common all 1:7.7+13ubuntu3 [22.4 kB]
      Get:11 http://archive.ubuntu.com/ubuntu xenial/main amd64 xfonts-encodings all 1:1.0.4-2 [573 kB]
      Get:12 http://archive.ubuntu.com/ubuntu xenial/main amd64 xfonts-utils amd64 1:7.7+3 [75.3 kB]
      Get:13 http://archive.ubuntu.com/ubuntu xenial/universe amd64 gsfonts-x11 all 0.24 [7,314 B]
      Get:14 http://archive.ubuntu.com/ubuntu xenial/main amd64 libdbi-perl amd64 1.634-1build1 [743 kB]
      Get:15 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libdbd-pg-perl amd64 3.5.3-1build1 [174 kB]
      Get:16 http://archive.ubuntu.com/ubuntu xenial/main amd64 libencode-locale-perl all 1.05-1 [12.3 kB]
      Get:17 http://archive.ubuntu.com/ubuntu xenial/main amd64 libtimedate-perl all 2.3000-2 [37.5 kB]
      Get:18 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhttp-date-perl all 6.02-1 [10.4 kB]
      Get:19 http://archive.ubuntu.com/ubuntu xenial/main amd64 libfile-listing-perl all 6.04-1 [9,774 B]
      Get:20 http://archive.ubuntu.com/ubuntu xenial/main amd64 libfont-afm-perl all 1.20-1 [14.3 kB]
      Get:21 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libgetopt-mixed-perl all 1.008-10.1 [18.0 kB]
      Get:22 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhtml-tagset-perl all 3.20-2 [13.5 kB]
      Get:23 http://archive.ubuntu.com/ubuntu xenial/main amd64 liburi-perl all 1.71-1 [76.9 kB]
      Get:24 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhtml-parser-perl amd64 3.72-1 [86.1 kB]
      Get:25 http://debian.opennms.org stable/main amd64 libopennmsdeps-java all 19.1.0-1 [164 MB]
      Get:26 http://archive.ubuntu.com/ubuntu xenial/main amd64 libio-html-perl all 1.001-1 [14.9 kB]
      Get:27 http://archive.ubuntu.com/ubuntu xenial/main amd64 liblwp-mediatypes-perl all 6.02-1 [21.7 kB]
      Get:28 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhttp-message-perl all 6.11-1 [74.3 kB]
      Get:29 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhtml-form-perl all 6.03-1 [23.5 kB]
      Get:30 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhtml-tree-perl all 5.03-2 [197 kB]
      Get:31 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhtml-format-perl all 2.11-2 [41.3 kB]
      Get:32 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhttp-cookies-perl all 6.01-1 [17.2 kB]
      Get:33 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhttp-daemon-perl all 6.01-1 [17.0 kB]
      Get:34 http://archive.ubuntu.com/ubuntu xenial/main amd64 libhttp-negotiate-perl all 6.00-2 [13.4 kB]
      Get:35 http://archive.ubuntu.com/ubuntu xenial/main amd64 libnet-ssleay-perl amd64 1.72-1build1 [259 kB]
      Get:36 http://archive.ubuntu.com/ubuntu xenial/main amd64 libio-socket-ssl-perl all 2.024-1 [159 kB]
      Get:37 http://archive.ubuntu.com/ubuntu xenial/main amd64 libnet-http-perl all 6.09-1 [24.0 kB]
      Get:38 http://archive.ubuntu.com/ubuntu xenial/main amd64 libwww-robotrules-perl all 6.01-1 [14.1 kB]
      Get:39 http://archive.ubuntu.com/ubuntu xenial/main amd64 libwww-perl all 6.15-1 [146 kB]
      Get:40 http://archive.ubuntu.com/ubuntu xenial/main amd64 liblwp-protocol-https-perl all 6.06-2 [8,682 B]
      Get:41 http://archive.ubuntu.com/ubuntu xenial/main amd64 libnet-smtp-ssl-perl all 1.03-1 [6,288 B]
      Get:42 http://archive.ubuntu.com/ubuntu xenial/main amd64 libmailtools-perl all 2.13-1 [82.6 kB]
      Get:43 http://archive.ubuntu.com/ubuntu xenial/main amd64 libnet-snmp-perl all 6.0.1-2 [107 kB]
      Get:44 http://archive.ubuntu.com/ubuntu xenial/main amd64 libtie-ixhash-perl all 1.23-2 [11.2 kB]
      Get:45 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxml-parser-perl amd64 2.44-1build1 [200 kB]
      Get:46 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxml-twig-perl all 1:3.48-1 [156 kB]
      Get:47 http://archive.ubuntu.com/ubuntu xenial/main amd64 libxml-xpathengine-perl all 0.13-1 [37.1 kB]
      Get:48 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 libxml2-utils amd64 2.9.3+dfsg1-1ubuntu0.2 [35.0 kB]
      Get:49 http://archive.ubuntu.com/ubuntu xenial/universe amd64 s-nail amd64 14.8.6-1 [353 kB]
      Get:50 http://archive.ubuntu.com/ubuntu xenial/main amd64 libauthen-sasl-perl all 2.1600-1 [48.7 kB]
      Get:51 http://debian.opennms.org stable/main amd64 iplike-pgsql95 amd64 2.0.6-1 [11.6 kB]
      Get:52 http://debian.opennms.org stable/main amd64 opennms-db all 19.1.0-1 [2,752 B]
      Get:53 http://debian.opennms.org stable/main amd64 opennms-common all 19.1.0-1 [281 MB]
      Get:54 http://debian.opennms.org stable/main amd64 opennms-server all 19.1.0-1 [4,366 B]
      Get:55 http://debian.opennms.org stable/main amd64 opennms-webapp-jetty all 19.1.0-1 [14.1 MB]
      Get:56 http://debian.opennms.org stable/main amd64 opennms all 19.1.0-1 [2,896 B]
      Get:57 http://debian.opennms.org stable/main amd64 opennms-source all 19.1.0-1 [122 MB]
      Get:58 http://debian.opennms.org stable/main amd64 oracle-java8-set-default all 8u111+8u111arm-1~webupd8~0 [6,188 B]
      Fetched 598 MB in 2min 3s (4,827 kB/s)
      Extracting templates from packages: 100%
      Preconfiguring packages ...
      Selecting previously unselected package libfontenc1:amd64.
      (Reading database ... 82547 files and directories currently installed.)
      Preparing to unpack .../libfontenc1_1%3a1.1.3-1_amd64.deb ...
      Unpacking libfontenc1:amd64 (1:1.1.3-1) ...
      Selecting previously unselected package libxfont1:amd64.
      Preparing to unpack .../libxfont1_1%3a1.5.1-1_amd64.deb ...
      Unpacking libxfont1:amd64 (1:1.5.1-1) ...
      Selecting previously unselected package binutils.
      Preparing to unpack .../binutils_2.26.1-1ubuntu1~16.04.3_amd64.deb ...
      Unpacking binutils (2.26.1-1ubuntu1~16.04.3) ...
      Selecting previously unselected package java-common.
      Preparing to unpack .../java-common_0.56ubuntu2_all.deb ...
      Unpacking java-common (0.56ubuntu2) ...
      Processing triggers for libc-bin (2.23-0ubuntu7) ...
      Processing triggers for man-db (2.7.5-1) ...
      Setting up binutils (2.26.1-1ubuntu1~16.04.3) ...
      Processing triggers for libc-bin (2.23-0ubuntu7) ...
      Selecting previously unselected package oracle-java8-installer.
      (Reading database ... 82773 files and directories currently installed.)
      Preparing to unpack .../oracle-java8-installer_8u111+8u111arm-1~webupd8~0_all.deb ...
      Unpacking oracle-java8-installer (8u111+8u111arm-1~webupd8~0) ...
      Selecting previously unselected package gsfonts.
      Preparing to unpack .../gsfonts_1%3a8.11+urwcyr1.0.7~pre44-4.2ubuntu1_all.deb ...
      Unpacking gsfonts (1:8.11+urwcyr1.0.7~pre44-4.2ubuntu1) ...
      Selecting previously unselected package x11-common.
      Preparing to unpack .../x11-common_1%3a7.7+13ubuntu3_all.deb ...
      Unpacking x11-common (1:7.7+13ubuntu3) ...
      Selecting previously unselected package xfonts-encodings.
      Preparing to unpack .../xfonts-encodings_1%3a1.0.4-2_all.deb ...
      Unpacking xfonts-encodings (1:1.0.4-2) ...
      Selecting previously unselected package xfonts-utils.
      Preparing to unpack .../xfonts-utils_1%3a7.7+3_amd64.deb ...
      Unpacking xfonts-utils (1:7.7+3) ...
      Selecting previously unselected package gsfonts-x11.
      Preparing to unpack .../gsfonts-x11_0.24_all.deb ...
      Unpacking gsfonts-x11 (0.24) ...
      Selecting previously unselected package libdbi-perl.
      Preparing to unpack .../libdbi-perl_1.634-1build1_amd64.deb ...
      Unpacking libdbi-perl (1.634-1build1) ...
      Selecting previously unselected package libdbd-pg-perl.
      Preparing to unpack .../libdbd-pg-perl_3.5.3-1build1_amd64.deb ...
      Unpacking libdbd-pg-perl (3.5.3-1build1) ...
      Selecting previously unselected package libencode-locale-perl.
      Preparing to unpack .../libencode-locale-perl_1.05-1_all.deb ...
      Unpacking libencode-locale-perl (1.05-1) ...
      Selecting previously unselected package libtimedate-perl.
      Preparing to unpack .../libtimedate-perl_2.3000-2_all.deb ...
      Unpacking libtimedate-perl (2.3000-2) ...
      Selecting previously unselected package libhttp-date-perl.
      Preparing to unpack .../libhttp-date-perl_6.02-1_all.deb ...
      Unpacking libhttp-date-perl (6.02-1) ...
      Selecting previously unselected package libfile-listing-perl.
      Preparing to unpack .../libfile-listing-perl_6.04-1_all.deb ...
      Unpacking libfile-listing-perl (6.04-1) ...
      Selecting previously unselected package libfont-afm-perl.
      Preparing to unpack .../libfont-afm-perl_1.20-1_all.deb ...
      Unpacking libfont-afm-perl (1.20-1) ...
      Selecting previously unselected package libgetopt-mixed-perl.
      Preparing to unpack .../libgetopt-mixed-perl_1.008-10.1_all.deb ...
      Unpacking libgetopt-mixed-perl (1.008-10.1) ...
      Selecting previously unselected package libhtml-tagset-perl.
      Preparing to unpack .../libhtml-tagset-perl_3.20-2_all.deb ...
      Unpacking libhtml-tagset-perl (3.20-2) ...
      Selecting previously unselected package liburi-perl.
      Preparing to unpack .../liburi-perl_1.71-1_all.deb ...
      Unpacking liburi-perl (1.71-1) ...
      Selecting previously unselected package libhtml-parser-perl.
      Preparing to unpack .../libhtml-parser-perl_3.72-1_amd64.deb ...
      Unpacking libhtml-parser-perl (3.72-1) ...
      Selecting previously unselected package libio-html-perl.
      Preparing to unpack .../libio-html-perl_1.001-1_all.deb ...
      Unpacking libio-html-perl (1.001-1) ...
      Selecting previously unselected package liblwp-mediatypes-perl.
      Preparing to unpack .../liblwp-mediatypes-perl_6.02-1_all.deb ...
      Unpacking liblwp-mediatypes-perl (6.02-1) ...
      Selecting previously unselected package libhttp-message-perl.
      Preparing to unpack .../libhttp-message-perl_6.11-1_all.deb ...
      Unpacking libhttp-message-perl (6.11-1) ...
      Selecting previously unselected package libhtml-form-perl.
      Preparing to unpack .../libhtml-form-perl_6.03-1_all.deb ...
      Unpacking libhtml-form-perl (6.03-1) ...
      Selecting previously unselected package libhtml-tree-perl.
      Preparing to unpack .../libhtml-tree-perl_5.03-2_all.deb ...
      Unpacking libhtml-tree-perl (5.03-2) ...
      Selecting previously unselected package libhtml-format-perl.
      Preparing to unpack .../libhtml-format-perl_2.11-2_all.deb ...
      Unpacking libhtml-format-perl (2.11-2) ...
      Selecting previously unselected package libhttp-cookies-perl.
      Preparing to unpack .../libhttp-cookies-perl_6.01-1_all.deb ...
      Unpacking libhttp-cookies-perl (6.01-1) ...
      Selecting previously unselected package libhttp-daemon-perl.
      Preparing to unpack .../libhttp-daemon-perl_6.01-1_all.deb ...
      Unpacking libhttp-daemon-perl (6.01-1) ...
      Selecting previously unselected package libhttp-negotiate-perl.
      Preparing to unpack .../libhttp-negotiate-perl_6.00-2_all.deb ...
      Unpacking libhttp-negotiate-perl (6.00-2) ...
      Selecting previously unselected package libnet-ssleay-perl.
      Preparing to unpack .../libnet-ssleay-perl_1.72-1build1_amd64.deb ...
      Unpacking libnet-ssleay-perl (1.72-1build1) ...
      Selecting previously unselected package libio-socket-ssl-perl.
      Preparing to unpack .../libio-socket-ssl-perl_2.024-1_all.deb ...
      Unpacking libio-socket-ssl-perl (2.024-1) ...
      Selecting previously unselected package libnet-http-perl.
      Preparing to unpack .../libnet-http-perl_6.09-1_all.deb ...
      Unpacking libnet-http-perl (6.09-1) ...
      Selecting previously unselected package libwww-robotrules-perl.
      Preparing to unpack .../libwww-robotrules-perl_6.01-1_all.deb ...
      Unpacking libwww-robotrules-perl (6.01-1) ...
      Selecting previously unselected package libwww-perl.
      Preparing to unpack .../libwww-perl_6.15-1_all.deb ...
      Unpacking libwww-perl (6.15-1) ...
      Selecting previously unselected package liblwp-protocol-https-perl.
      Preparing to unpack .../liblwp-protocol-https-perl_6.06-2_all.deb ...
      Unpacking liblwp-protocol-https-perl (6.06-2) ...
      Selecting previously unselected package libnet-smtp-ssl-perl.
      Preparing to unpack .../libnet-smtp-ssl-perl_1.03-1_all.deb ...
      Unpacking libnet-smtp-ssl-perl (1.03-1) ...
      Selecting previously unselected package libmailtools-perl.
      Preparing to unpack .../libmailtools-perl_2.13-1_all.deb ...
      Unpacking libmailtools-perl (2.13-1) ...
      Selecting previously unselected package libnet-snmp-perl.
      Preparing to unpack .../libnet-snmp-perl_6.0.1-2_all.deb ...
      Unpacking libnet-snmp-perl (6.0.1-2) ...
      Selecting previously unselected package jicmp.
      Preparing to unpack .../jicmp_2.0.2-1_amd64.deb ...
      Unpacking jicmp (2.0.2-1) ...
      Selecting previously unselected package jicmp6.
      Preparing to unpack .../jicmp6_2.0.2-1_amd64.deb ...
      Unpacking jicmp6 (2.0.2-1) ...
      Selecting previously unselected package libopennms-java.
      Preparing to unpack .../libopennms-java_19.1.0-1_all.deb ...
      Unpacking libopennms-java (19.1.0-1) ...
      Selecting previously unselected package libopennmsdeps-java.
      Preparing to unpack .../libopennmsdeps-java_19.1.0-1_all.deb ...
      Unpacking libopennmsdeps-java (19.1.0-1) ...
      Selecting previously unselected package libtie-ixhash-perl.
      Preparing to unpack .../libtie-ixhash-perl_1.23-2_all.deb ...
      Unpacking libtie-ixhash-perl (1.23-2) ...
      Selecting previously unselected package libxml-parser-perl.
      Preparing to unpack .../libxml-parser-perl_2.44-1build1_amd64.deb ...
      Unpacking libxml-parser-perl (2.44-1build1) ...
      Selecting previously unselected package libxml-twig-perl.
      Preparing to unpack .../libxml-twig-perl_1%3a3.48-1_all.deb ...
      Unpacking libxml-twig-perl (1:3.48-1) ...
      Selecting previously unselected package libxml-xpathengine-perl.
      Preparing to unpack .../libxml-xpathengine-perl_0.13-1_all.deb ...
      Unpacking libxml-xpathengine-perl (0.13-1) ...
      Selecting previously unselected package libxml2-utils.
      Preparing to unpack .../libxml2-utils_2.9.3+dfsg1-1ubuntu0.2_amd64.deb ...
      Unpacking libxml2-utils (2.9.3+dfsg1-1ubuntu0.2) ...
      Selecting previously unselected package iplike-pgsql95.
      Preparing to unpack .../iplike-pgsql95_2.0.6-1_amd64.deb ...
      Unpacking iplike-pgsql95 (2.0.6-1) ...
      Selecting previously unselected package opennms-db.
      Preparing to unpack .../opennms-db_19.1.0-1_all.deb ...
      Unpacking opennms-db (19.1.0-1) ...
      Selecting previously unselected package opennms-common.
      Preparing to unpack .../opennms-common_19.1.0-1_all.deb ...
      Unpacking opennms-common (19.1.0-1) ...
      Selecting previously unselected package s-nail.
      Preparing to unpack .../s-nail_14.8.6-1_amd64.deb ...
      Unpacking s-nail (14.8.6-1) ...
      Selecting previously unselected package opennms-server.
      Preparing to unpack .../opennms-server_19.1.0-1_all.deb ...
      Unpacking opennms-server (19.1.0-1) ...
      Selecting previously unselected package opennms-webapp-jetty.
      Preparing to unpack .../opennms-webapp-jetty_19.1.0-1_all.deb ...
      Unpacking opennms-webapp-jetty (19.1.0-1) ...
      Selecting previously unselected package opennms.
      Preparing to unpack .../opennms_19.1.0-1_all.deb ...
      Unpacking opennms (19.1.0-1) ...
      Selecting previously unselected package opennms-source.
      Preparing to unpack .../opennms-source_19.1.0-1_all.deb ...
      Unpacking opennms-source (19.1.0-1) ...
      Selecting previously unselected package oracle-java8-set-default.
      Preparing to unpack .../oracle-java8-set-default_8u111+8u111arm-1~webupd8~0_all.deb ...
      Unpacking oracle-java8-set-default (8u111+8u111arm-1~webupd8~0) ...
      Selecting previously unselected package libauthen-sasl-perl.
      Preparing to unpack .../libauthen-sasl-perl_2.1600-1_all.deb ...
      Unpacking libauthen-sasl-perl (2.1600-1) ...
      Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
      Processing triggers for mime-support (3.59ubuntu1) ...
      Processing triggers for systemd (229-4ubuntu17) ...
      Processing triggers for ureadahead (0.100.0-19) ...
      Processing triggers for man-db (2.7.5-1) ...
      Setting up libfontenc1:amd64 (1:1.1.3-1) ...
      Setting up libxfont1:amd64 (1:1.5.1-1) ...
      Setting up java-common (0.56ubuntu2) ...
      Setting up oracle-java8-installer (8u111+8u111arm-1~webupd8~0) ...
      No /var/cache/oracle-jdk8-installer/wgetrc file found.
      Creating /var/cache/oracle-jdk8-installer/wgetrc and
      using default oracle-java8-installer wgetrc settings for it.
      Downloading Oracle Java 8...
      --2017-06-07 21:09:41--  http://download.oracle.com/otn-pub/java/jdk/8u111-b14/jdk-8u111-linux-x64.tar.gz
      Resolving download.oracle.com (download.oracle.com)... 92.123.195.10, 92.123.195.26
      Connecting to download.oracle.com (download.oracle.com)|92.123.195.10|:80... connected.
      HTTP request sent, awaiting response... 302 Moved Temporarily
      Location: https://edelivery.oracle.com/otn-pub/java/jdk/8u111-b14/jdk-8u111-linux-x64.tar.gz [following]
      --2017-06-07 21:09:43--  https://edelivery.oracle.com/otn-pub/java/jdk/8u111-b14/jdk-8u111-linux-x64.tar.gz
      Resolving edelivery.oracle.com (edelivery.oracle.com)... 104.84.166.125, 2a02:26f0:ef:18c::2d3e, 2a02:26f0:ef:196::2d3e
      Connecting to edelivery.oracle.com (edelivery.oracle.com)|104.84.166.125|:443... connected.
      HTTP request sent, awaiting response... 302 Moved Temporarily
      Location: http://download.oracle.com/otn-pub/java/jdk/8u111-b14/jdk-8u111-linux-x64.tar.gz?AuthParam=1496869908_7c0ffa8cff3482b38a5aa7fd0549a3c7 [following]
      --2017-06-07 21:09:46--  http://download.oracle.com/otn-pub/java/jdk/8u111-b14/jdk-8u111-linux-x64.tar.gz?AuthParam=1496869908_7c0ffa8cff3482b38a5aa7fd0549a3c7
      Connecting to download.oracle.com (download.oracle.com)|92.123.195.10|:80... connected.
      HTTP request sent, awaiting response... 404 Not Found
      2017-06-07 21:09:47 ERROR 404: Not Found.
      
      download failed
      Oracle JDK 8 is NOT installed.
      dpkg: error processing package oracle-java8-installer (--configure):
       subprocess installed post-installation script returned error exit status 1
      Setting up gsfonts (1:8.11+urwcyr1.0.7~pre44-4.2ubuntu1) ...
      Setting up x11-common (1:7.7+13ubuntu3) ...
      update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
      Setting up xfonts-encodings (1:1.0.4-2) ...
      Setting up xfonts-utils (1:7.7+3) ...
      Setting up gsfonts-x11 (0.24) ...
      Setting up libdbi-perl (1.634-1build1) ...
      Setting up libdbd-pg-perl (3.5.3-1build1) ...
      Setting up libencode-locale-perl (1.05-1) ...
      Setting up libtimedate-perl (2.3000-2) ...
      Setting up libhttp-date-perl (6.02-1) ...
      Setting up libfile-listing-perl (6.04-1) ...
      Setting up libfont-afm-perl (1.20-1) ...
      Setting up libgetopt-mixed-perl (1.008-10.1) ...
      Setting up libhtml-tagset-perl (3.20-2) ...
      Setting up liburi-perl (1.71-1) ...
      Setting up libhtml-parser-perl (3.72-1) ...
      Setting up libio-html-perl (1.001-1) ...
      Setting up liblwp-mediatypes-perl (6.02-1) ...
      Setting up libhttp-message-perl (6.11-1) ...
      Setting up libhtml-form-perl (6.03-1) ...
      Setting up libhtml-tree-perl (5.03-2) ...
      Setting up libhtml-format-perl (2.11-2) ...
      Setting up libhttp-cookies-perl (6.01-1) ...
      Setting up libhttp-daemon-perl (6.01-1) ...
      Setting up libhttp-negotiate-perl (6.00-2) ...
      Setting up libnet-ssleay-perl (1.72-1build1) ...
      Setting up libio-socket-ssl-perl (2.024-1) ...
      Setting up libnet-http-perl (6.09-1) ...
      Setting up libwww-robotrules-perl (6.01-1) ...
      Setting up libnet-smtp-ssl-perl (1.03-1) ...
      Setting up libmailtools-perl (2.13-1) ...
      Setting up libnet-snmp-perl (6.0.1-2) ...
      Setting up jicmp (2.0.2-1) ...
      Setting up jicmp6 (2.0.2-1) ...
      dpkg: dependency problems prevent configuration of libopennms-java:
       libopennms-java depends on oracle-java8-installer | openjdk-8-jre | java8-runtime | java8-runtime-headless; however:
        Package oracle-java8-installer is not configured yet.
        Package openjdk-8-jre is not installed.
        Package java8-runtime is not installed.
        Package oracle-java8-installer which provides java8-runtime is not configured yet.
        Package java8-runtime-headless is not installed.
        Package oracle-java8-installer which provides java8-runtime-headless is not configured yet.
      
      dpkg: error processing package libopennms-java (--configure):
       dependency problems - leaving unconfigured
      No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                   dpkg: dependency problems prevent configuration of libopennmsdeps-java:
       libopennmsdeps-java depends on oracle-java8-installer | openjdk-8-jre | java8-runtime | java8-runtime-headless; however:
        Package oracle-java8-installer is not configured yet.
        Package openjdk-8-jre is not installed.
        Package java8-runtime is not installed.
        Package oracle-java8-installer which provides java8-runtime is not configured yet.
        Package java8-runtime-headless is not installed.
        Package oracle-java8-installer which provides java8-runtime-headless is not configured yet.
      
      dpkg: error processing package libopennmsdeps-java (--configure):
       dependency problems - leaving unconfigured
      Setting up libtie-ixhash-perl (1.23-2) ...
      Setting up libxml-xpathengine-perl (0.13-1) ...
      Setting up libxml2-utils (2.9.3+dfsg1-1ubuntu0.2) ...
      Setting up iplike-pgsql95 (2.0.6-1) ...
      update-alternatives: using /usr/sbin/install_iplike-95.sh to provide /usr/sbin/install_iplike.sh (install_iplike.sh) in auto mode
      update-alternatives: using /usr/lib/postgresql/9.5/lib/iplike.so to provide /usr/share/java/opennms/iplike.so (iplike.so) in auto mode
      Setting up opennms-db (19.1.0-1) ...
      Setting up opennms-common (19.1.0-1) ...
      Setting up s-nail (14.8.6-1) ...
      update-alternatives: using /usr/bin/s-nail to provide /usr/bin/mailx (mailx) in auto mode
      dpkg: dependency problems prevent configuration of opennms-server:
       opennms-server depends on libopennms-java (= 19.1.0-1); however:
        Package libopennms-java is not configured yet.
       opennms-server depends on libopennmsdeps-java (= 19.1.0-1); however:
        Package libopennmsdeps-java is not configured yet.
      
      dpkg: error processing package opennms-server (--configure):
       dependency problems - leaving unconfigured
      No apport report written because MaxReports is reached already
                                                                    No apport report written because MaxReports is reached already
                                                                                                                                  No apport report written because MaxReports is reached already
                                                         dpkg: dependency problems prevent configuration of opennms-webapp-jetty:
       opennms-webapp-jetty depends on opennms-server (= 19.1.0-1); however:
        Package opennms-server is not configured yet.
      
      dpkg: error processing package opennms-webapp-jetty (--configure):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of opennms:
       opennms depends on opennms-server (= 19.1.0-1); however:
        Package opennms-server is not configured yet.
       opennms depends on opennms-webapp-jetty (= 19.1.0-1); however:
        Package opennms-webapp-jetty is not configured yet.
      
      dpkg: error processing package opennms (--configure):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of opennms-source:
       opennms-source depends on opennms-webapp-jetty (= 19.1.0-1); however:
        Package opennms-webapp-jetty is not configured yet.
      
      dpkg: error processing package opennms-source (--configure):
       dependency problems - leaving unconfigured
      dpkg: dependency prNo apport report written because MaxReports is reached already
                                                                                       No apport report written because MaxReports is reached already
              oblems prevent configuration of oracle-java8-set-default:
       oracle-java8-set-default depends on oracle-java8-installer; however:
        Package oracle-java8-installer is not configured yet.
      
      dpkg: error processing package oracle-java8-set-default (--configure):
       dependency problems - leaving unconfigured
      Setting up libauthen-sasl-perl (2.1600-1) ...
      Setting up libwww-perl (6.15-1) ...
      Setting up liblwp-protocol-https-perl (6.06-2) ...
      Setting up libxml-parser-perl (2.44-1build1) ...
      Setting up libxml-twig-perl (1:3.48-1) ...
      Processing triggers for libc-bin (2.23-0ubuntu7) ...
      Processing triggers for systemd (229-4ubuntu17) ...
      Processing triggers for ureadahead (0.100.0-19) ...
      Errors were encountered while processing:
       oracle-java8-installer
       libopennms-java
       libopennmsdeps-java
       opennms-server
       opennms-webapp-jetty
       opennms
       opennms-source
       oracle-java8-set-default
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      FAILED
      

        Attachments

          Activity

            People

            • Assignee:
              ranger Benjamin Reed
              Reporter:
              indigo Ronny Trommer
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: