Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-9472

AMQP features broken after Camel upgrade

    XMLWordPrintable

    Details

    • Sprint:
      Horizon - June 21st

      Description

      After upgrading past Camel 2.14, Camel changed their camel-amqp feature to use a different connection factory to provide compatibility with AMQP 1.0. To preserve the AMQP 0-9-1 protocol compatibility (if desired), we need to provide a connection factory JAR when we install our AMQP features. Another option would be to drop support for AMQP 0-9-1 and just use the new AMQP 1.0 connection factory.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              seth Seth Leger (Inactive)
              Reporter:
              seth Seth Leger (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: