Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-9640

yum error when upgrading from Meridian 2016 to Meridian 2017 with XML protocol package

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Meridian-2016.1.6
    • Fix Version/s: Meridian-2017.1.0
    • Component/s: Build / Packaging
    • Security Level: Default (Default Security Scheme)
    • Labels:
      None
    • Sprint:
      Horizon - September 20th, Horizon - September 27th

      Description

      With the meridian-plugin-protocol-xml-2016.1.6-1.noarch package installed, and the Meridian yum repo set to:

      https://packages/branches/release-2017.1.0/rhel$releasever

      the upgrade to 2017 fails with:

      Resolving Dependencies
      --> Running transaction check
      ---> Package jicmp.x86_64 0:1.4.5-2 will be updated
      ---> Package jicmp.x86_64 0:2.0.3-1.el7.centos will be an update
      ---> Package jicmp6.x86_64 0:1.2.4-1 will be updated
      ---> Package jicmp6.x86_64 0:2.0.2-1.el7.centos will be an update
      ---> Package jrrd2.x86_64 1:2.0.3-3.el7.centos will be updated
      ---> Package jrrd2.x86_64 1:2.0.3-4.el7.centos will be an update
      ---> Package meridian.noarch 0:2016.1.6-1 will be updated
      ---> Package meridian.noarch 0:2017.1.0-0.20170919.prime54.release.2017.1.0.50 will be an update
      ---> Package meridian-core.noarch 0:2016.1.6-1 will be updated
      --> Processing Dependency: meridian-core = 2016.1.6-1 for package: meridian-plugin-protocol-xml-2016.1.6-1.noarch
      --> Processing Dependency: meridian-core = 2016.1.6-1 for package: meridian-plugin-protocol-xml-2016.1.6-1.noarch
      ---> Package meridian-core.noarch 0:2017.1.0-0.20170919.prime54.release.2017.1.0.50 will be an update
      ---> Package meridian-plugin-protocol-radius.noarch 0:2016.1.6-1 will be updated
      ---> Package meridian-plugin-protocol-radius.noarch 0:2017.1.0-0.20170919.prime54.release.2017.1.0.50 will be an update
      ---> Package meridian-plugin-ticketer-rt.noarch 0:2016.1.6-1 will be updated
      ---> Package meridian-plugin-ticketer-rt.noarch 0:2017.1.0-0.20170919.prime54.release.2017.1.0.50 will be an update
      ---> Package meridian-webapp-jetty.noarch 0:2016.1.6-1 will be updated
      ---> Package meridian-webapp-jetty.noarch 0:2017.1.0-0.20170919.prime54.release.2017.1.0.50 will be an update
      ---> Package rrdtool.x86_64 0:1.5.5-0.4.el7.centos will be updated
      ---> Package rrdtool.x86_64 0:1.6.0-0.3.opennms.el7.centos will be an update
      ---> Package rrdtool-perl.x86_64 0:1.5.5-0.4.el7.centos will be obsoleted
      ---> Package rrdtool-perl.x86_64 0:1.6.0-0.3.opennms.el7.centos will be obsoleting
      --> Finished Dependency Resolution
      Error: Package: meridian-plugin-protocol-xml-2016.1.6-1.noarch (@meridian)
      Requires: meridian-core = 2016.1.6-1
      Removing: meridian-core-2016.1.6-1.noarch (@meridian)
      meridian-core = 2016.1.6-1
      Updated By: meridian-core-2017.1.0-0.20170919.prime54.release.2017.1.0.50.noarch (meridian)
      meridian-core = 2017.1.0-0.20170919.prime54.release.2017.1.0.50
      You could try using --skip-broken to work around the problem
      You could try running: rpm -Va --nofiles --nodigest

      As a workaround, you can stop OpenNMS and run

      yum remove meridian-plugin-protocol-xml

      before upgrading.

       

       

        Attachments

          Activity

            People

            • Assignee:
              ranger Benjamin Reed
              Reporter:
              tarus Tarus Balog
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: