Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-9736

Thresholding not working on HTTP data collections

    XMLWordPrintable

    Details

      Description

      Thresholding on HTTP collections stopped working. SNMP-based collection thresholding still works. Here are debug logs showing that the data is collected, but the thresholder can't find it.

       

      2017-11-13 21:00:33,065 DEBUG [Collectd-Thread-37-of-50] o.o.n.c.s.AbstractCollectionResource: Adding attribute org.opennms.netmgt.collection.dto.CollectionSetDTO$2: Attribute[4sqlSlaveLag:0] to group AttrGroupType[name=4sqlSlaveLag, ifType=all] for node@1154
      2017-11-13 21:00:33,077 DEBUG [Collectd-Thread-37-of-50] o.o.n.c.a.AttributeGroup: Visiting Group AttrGroupType[name=4sqlSlaveLag, ifType=all] for node@1154
      2017-11-13 21:00:33,077 DEBUG [Collectd-Thread-37-of-50] o.o.n.c.a.AttributeGroup: AttrGroupType[name=4sqlSlaveLag, ifType=all] for node@1154.shouldPersist = true
      2017-11-13 21:00:33,080 INFO [Collectd-Thread-37-of-50] o.o.n.r.RrdMetaDataUtils: createMetaDataFile: creating meta data file /weebly/data/opennms/rrd/snmp/1154/4sqlSlaveLag.meta with values '{GROUP=4sqlSlaveLag, 4sqlSlaveLag=4sqlSlaveLag}'
      2017-11-13 21:00:33,081 DEBUG [Collectd-Thread-37-of-50] o.o.n.r.j.JRobinRrdStrategy: createDefinition: filename [/weebly/data/opennms/rrd/snmp/1154/4sqlSlaveLag.jrb] already exists returning null as definition
      2017-11-13 21:00:33,082 INFO [Collectd-Thread-37-of-50] o.o.n.c.p.r.RrdPersistOperationBuilder: updateRRD: updating RRD file /weebly/data/opennms/rrd/snmp/1154/4sqlSlaveLag.jrb with values '1510606833:0'
      2017-11-13 21:01:03,469 INFO [Collectd-Thread-29-of-50] o.o.n.t.ThresholdingSet: applyThresholds: Processing threshold 4sqlSlaveLag : {evaluator=HIGH, dsName=4sqlSlaveLag, dsType=node, evaluators=[\{ds=4sqlSlaveLag, value=36400.0, rearm=8000.0, trigger=2}]} on resource node[1154]
      2017-11-13 21:01:03,471 INFO [Collectd-Thread-29-of-50] o.o.n.t.CollectionResourceWrapper: getAttributeValue: can't find attribute called 4sqlSlaveLag on node[1154]

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              rhesse Richard Hesse (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:

                  Git Integration