Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-9818

alarm-change-notifier feature fails to install due to missing dependencies

    XMLWordPrintable

    Details

    • Sprint:
      Horizon - Jan 10th 2018

      Description

      Installing the alarm-change-notifier feature currently fails with:

      Error executing command: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=alarm-change-notifier; type=karaf.feature; version="[22.0.0.SNAPSHOT,22.0.0.SNAPSHOT]"; filter:="(&(osgi.identity=alarm-change-notifier)(type=karaf.feature)(version>=22.0.0.SNAPSHOT)(version<=22.0.0.SNAPSHOT))" [caused by: Unable to resolve alarm-change-notifier/22.0.0.SNAPSHOT: missing requirement [alarm-change-notifier/22.0.0.SNAPSHOT] osgi.identity; osgi.identity=pgjdbc-ng; type=osgi.bundle; version="[0.6.0.osgi,0.6.0.osgi]"; resolution:=mandatory [caused by: Unable to resolve pgjdbc-ng/0.6.0.osgi: missing requirement [pgjdbc-ng/0.6.0.osgi] osgi.wiring.package; filter:="(&(osgi.wiring.package=io.netty.bootstrap)(version>=4.0.0)(!(version>=4.1.0)))"]]
      

        Attachments

          Activity

            People

            • Assignee:
              j-white Jesse White
              Reporter:
              j-white Jesse White
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: