Uploaded image for project: 'OpenNMS'
  1. OpenNMS
  2. NMS-9925

Can't install OpenNMS on Ubuntu 18.04

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 21.0.5, 22.0.0
    • Fix Version/s: 22.0.2
    • Component/s: Installation
    • Security Level: Default (Default Security Scheme)
    • Labels:
    • Environment:
      Ubuntu 18.04 LTS x64 (beta)
    • Sprint:
      Horizon - March 14th 2018, Horizon - March 21st 2018, Horizon - June 27th 2018, Horizon - July 4th 2018, Horizon - July 11th 2018

      Description

      It is not possible to install OpenNMS 21.0.5 on Ubuntu 18.04. It depends on PostgreSQL which is installed in version 10 and depends on IP like. We don't provide iplike-psql10 in the repositories and the install fails with the following error message:

      root@ubuntu-bionic:~/opennms-install-1.1# apt-get install opennms
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
      
      The following packages have unmet dependencies:
       opennms : Depends: opennms-db (= 21.0.5-1) but it is not going to be installed
      E: Unable to correct problems, you have held broken packages.
      

      Trying to install the opennms-db package gives the following error message:

      oot@ubuntu-bionic:~/opennms-install-1.1# apt-get install opennms-db
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
      
      The following packages have unmet dependencies:
       opennms-db : Depends: postgresql-10.0 but it is not installable or
                             postgresql-9.6 but it is not installable or
                             postgresql-9.5 but it is not installable or
                             postgresql-9.4 but it is not installable or
                             postgresql-9.3 but it is not installable or
                             postgresql-9.2 but it is not installable or
                             postgresql-9.1 but it is not installable
                    Depends: iplike-pgsql10.0 but it is not installable or
                             iplike-pgsql96 but it is not going to be installed or
                             iplike-pgsql95 but it is not going to be installed or
                             iplike-pgsql94 but it is not going to be installed or
                             iplike-pgsql93 but it is not going to be installed or
                             iplike-pgsql92 but it is not going to be installed or
                             iplike-pgsql91 but it is not going to be installed
      E: Unable to correct problems, you have held broken packages.
      

        Attachments

          Activity

            People

            Assignee:
            ranger Benjamin Reed
            Reporter:
            fuhrmann Marcel Fuhrmann
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: